Commit cabde950 authored by Dmitriy Zaporozhets's avatar Dmitriy Zaporozhets
Browse files

ubuntu instal scripts

parent 1bf775d5
......@@ -15,7 +15,6 @@ gem "six"
gem "therubyracer"
gem "faker"
gem "seed-fu", "~> 2.1.0"
gem "inifile"
gem "pygments.rb", "0.2.3"
gem "thin"
gem "git"
......
......@@ -112,7 +112,6 @@ GEM
hashery (1.4.0)
hike (1.2.1)
i18n (0.6.0)
inifile (0.4.1)
jquery-rails (1.0.17)
railties (~> 3.0)
thor (~> 0.14)
......@@ -271,7 +270,6 @@ DEPENDENCIES
gitolite!
grit!
haml-rails
inifile
jquery-rails
kaminari
launchy
......
......@@ -32,13 +32,6 @@ cd gitlabhq/
sudo pip install pygments
sudo apt-get install python-dev
 
# give your user access to remove git repo
# Ex.
# If you are going to use user 'gitlabhq' for rails server
# gitlabhq ALL = (git) NOPASSWD: /bin/rm" | sudo tee -a /etc/sudoers
#
echo "USERNAME ALL = (git) NOPASSWD: /bin/rm" | sudo tee -a /etc/sudoers
sudo gem install bundler
 
bundle install --without development test
......@@ -107,7 +100,7 @@ gl-setup ~/rails.pub
## Install ruby 1.9.2
 
```bash
sudo aptitude install git-core curl gcc checkinstall libxml2-dev libxslt-dev sqlite3 libsqlite3-dev libcurl4-openssl-dev libreadline5-dev libc6-dev libssl-dev libmysql++-dev make build-essential zlib1g-dev
sudo aptitude install git-core openssh-server curl gcc checkinstall libxml2-dev libxslt-dev sqlite3 libsqlite3-dev libcurl4-openssl-dev libreadline5-dev libc6-dev libssl-dev libmysql++-dev make build-essential zlib1g-dev
 
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
 
......
Ubuntu installation
1. install git & generate ssh key
2. install ruby
./ubuntu_ruby.sh
3. install git user & gitolite with umask 0007
./ubuntu_gitolite.sh
4. logout
5. install gitlabhq
./ubuntu_gitlab.sh
6 start server
sudo pip install pygments
sudo apt-get install python-dev
sudo gem install bundler
bundle install --without development test
bundle exec rake db:setup RAILS_ENV=production
bundle exec rake db:seed_fu RAILS_ENV=production
sudo adduser \
--system \
--shell /bin/sh \
--gecos 'git version control' \
--group \
--disabled-password \
--home /home/git \
git
PATH=/home/dzaporozhets/bin:$PATH
# Add your user to git group
sudo usermod -a -G git `eval whoami`
# copy your pub key to git home
sudo cp ~/.ssh/id_rsa.pub /home/git/rails.pub
# clone gitolite
sudo -u git -H git clone git://github.com/gitlabhq/gitolite /home/git/gitolite
# install gitolite
sudo -u git -H /home/git/gitolite/src/gl-system-install
# Setup (Dont forget to set umask as 0007!!)
sudo -u git -H /home/git/bin/gl-setup /home/git/rails.pub
echo "Done"
# install all packages
sudo apt-get install git-core openssh-server curl gcc checkinstall libxml2-dev libxslt-dev sqlite3 libsqlite3-dev libcurl4-openssl-dev libreadline5-dev libc6-dev libssl-dev libmysql++-dev make build-essential zlib1g-dev
# get ruby 1.9.2
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xfvz ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure
make
sudo make install
echo "Done"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment