Bump knapsack to 1.14.0

What does this MR do?

  • Bump knapsack to 1.14.0
  • Remove workaround in duplicated gem installation in the build prep script (scripts/prepare_build.sh).
  • Pin knapsack as 1.14.0 for parallel jobs on CI
  • Remove knapsack from the main Gemfile

Are there points in the code the reviewer needs to double check?

No.

Why was this MR needed?

To keep gems up to date and to clarify which gem is used on CI.

Does this MR meet the acceptance criteria?

What are the relevant issue numbers?

Closes #34902 (closed)

Edited by username-removed-100770