Ubuntu 16.04 packager.io amendment

What does this MR do?

Amends the packager.io configuration file to create a build for Ubuntu 16.04.

Are there points in the code the reviewer needs to double check?

Verify no additional packages are required for Ubuntu 16.04 from the Ubuntu 14.04 build requirements

Why was this MR needed?

Packager.io does not support Ubuntu 16.04.

Screenshots (if relevant)

N/A

Does this MR meet the acceptance criteria?

Note that this is "just" a builder amendment, so many of these items are not relevant (e.g. documentation amendments, API support). Also, this commit was made using the Web UI and to support the requirement for the Changelog, I have had to make this change via two file edits. You may wish to cherry-pick just the .pcgr.yml file?

What are the relevant issue numbers?

None